Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 6
Registered: ‎05-13-2013

7D Mark ii Locks Up

I bought a used 7D Mark ii and it worked fine for a couple of weeks. About 10 days ago, it developed problems. After about 1/2 hour of shooting JPEGs, it would not auto-focus, and the shutter would not work. The number of images remaining started blinking. I can clear the problem temporarily by opening the card slot cover (beeper sounds) and removing and replacing the card, but the problem returns after shooting for a while. I have tried reformatting the card, using a different card and a different battery. Does anyone have any suggestions other than returning the camera? Thanks.
Reputable Contributor
Posts: 827
Registered: ‎02-06-2013

Re: 7D Mark ii Locks Up

Wow...tough problem to have.  The only thing I can think of is that you had too many things (noise reduction) turned on and the camera was too busy saving the files (buffer filled up).  Even without the noise reduction options, this happens to me sometimes when I was shooting birds at 10fps in RAW mode.

 

The worst reduction is the "Long Exposure Noise Reduction", it slows the camera down to a crawl. I'd turn off all selectable noise reduction and retry.  If this doesn't work then there's a problem with the camera...

 

 

================================================
Diverhank's photos on Flickr
Honored Contributor
Posts: 5,251
Registered: ‎08-13-2015

Re: 7D Mark ii Locks Up

Goofy behavior frequently seems to go hand in hand with unreliable memory cards.

 

Use just one memory card, until you can nail down what the fault could be.  Never use micro-SD cards, because the adapters are unreliable.  Always perform a "low level format" on a "new" memory card in the camera prior to first use.  Always.  Stick to name brand cards: like Sandisk or Lexar. 

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Occasional Contributor
Posts: 6
Registered: ‎05-13-2013

Re: 7D Mark ii Locks Up

Thanks, Diverhank, but Long Exposure Noise Reduction was already turned off. After more testing today, I was able to shoot about 400 images at 10 fps with no problem. I let the camera rest for 5-10 minutes and then all of the problems came back. I also noticed that the Viewfinder was dark, and that the shutter would only release I removedf the battery, so the camera is going back.

Occasional Contributor
Posts: 6
Registered: ‎05-13-2013

Re: 7D Mark ii Locks Up

Thanks for your reply, Waddizzle. I thought low level formatting was going to cure my problem also.  Yesterday the camera worked fine shooting a long burst of about 400 JPEGs at 10 fps in my back yard, but locked up again later in the morning when I tried to do some birding. After more testing today, I was able to shoot a similar burst with no problem. I let the camera rest for 5-10 minutes and then all of the problems came back. I also noticed that the Viewfinder was dark, and that the shutter would only release I removed the battery, so the camera is going back.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement