Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 4
Registered: ‎04-19-2017
Accepted Solution

T6- PLEASE HELP! brand new camera, and certain functions are acting up!

So, this is my first nice camera I have ever owned. So I am new to all of this. I have the EOS Rebel T6..

 

It was bought a little over 2 months ago, so the problems I am having with it are scaring me because I haven't even had it that long for these things to be happening! I am very careful with it (like a newborn baby) and when it is not in use, it is in the camera bag I have. Has NOT been exposed to water, dirt, food...etc. So I need help!!

 

Problem number 1: 

 

Yesterday I got it out to take some pics at my salon.. I took the lense cap off, got my subject in focus and snapped a picture. Went to look at the playback screen and half the picture was black? Hmm..funny...because when I look through the peep hole at my subject nothing is blocking the lense or is in my way of taking a picture. So I took another picture. Once again, half the picture was black. I took my lense off, making sure nothing was blocking my view and I coulnd't seem to find the problem.

 

Problem number 2:

 

So, then I went to erase the bad pictures I had just taken, my "SET" button (in the middle of the ISO, AF & WB buttons)

wont work.... I click the trash can to erase the picture and then try to click the SET button saying its okay to erase, it disappers and the picture is still there. So then I go to the MENU button..trying to see if the SET button will work anywhere else on my camera. I try to click on one of the tabs and it jumps to another tab on the menu...

 

Problem number 3: (This problem just arose)

 

Now my camera isn't taking a picture AT ALL. And to make matters worse the camera is NOT saying "busy".... 

normally when there is an issue it says "busy".... well its not doing that. The lense cap is off, and its in the Auto Mode.

 

PLEASE PLEASE HELP!!!! Someone who knows more about this than I do! Is this a technical problem? Or something on my end that I can fix?? I paid good money for this camera, and was looking into upgrading to another lense rather than using the kit lense it came with. I am super excited to use it but right now I cant do crap with it!!!

 

 

Respected Contributor
Posts: 1,909
Registered: ‎02-17-2016

Re: T6- PLEASE HELP! brand new camera, and certain functions are acting up!

It sounds like a defective mirror.

 

Go outside, put the camera in green square Auto and take a picture. Still have the black bar?

 

Does the T6 have a lock switch? That might prevent the set button from working.

 

If none of this resolves it, call Canon. You might have to send the camera back for repair.

New Contributor
Posts: 4
Registered: ‎04-19-2017

Re: T6- PLEASE HELP! brand new camera, and certain functions are acting up!

[ Edited ]

Okay, I just switched the lense from Auto Focus to Manual Focus and it took a picture.. and the picture isn't half black..? But it still will not take a picture when I put it back in Auto Focus.

AND- it WILL take a picture when I put it in Live Mode and put it in AUTO FOCUS..?

Not sure about the lock switch? But I don't think it has one. At this point, since my SET button isn't working..I might have messed up a setting in the menu and didn't know it and thats why it is acting weird.

New Contributor
Posts: 4
Registered: ‎04-19-2017

Re: T6- PLEASE HELP! brand new camera, and certain functions are acting up!

I think the main problem now is my SET button isn't working.. if that was working it would be easier for me to try to go to the menu and fix my settings or see if there was a setting I accidentally disabled or enabled.. but since my set button is not working right I can't do that... Smiley Sad
Frequent Contributor
Posts: 113
Registered: ‎12-03-2016

Re: T6- PLEASE HELP! brand new camera, and certain functions are acting up!

At two months old, your camera is still under warranty.  Have you called Canon's excellent customer service department for help with this issue?  Worst case scenario is they will fix it or replace it at no charge to you.

Super Contributor
Posts: 179
Registered: ‎01-31-2017

Re: T6- PLEASE HELP! brand new camera, and certain functions are acting up!

[ Edited ]

rachelmccart wrote:

Okay, I just switched the lense from Auto Focus to Manual Focus and it took a picture.. and the picture isn't half black..? But it still will not take a picture when I put it back in Auto Focus.

AND- it WILL take a picture when I put it in Live Mode and put it in AUTO FOCUS..?

Not sure about the lock switch? But I don't think it has one. At this point, since my SET button isn't working..I might have messed up a setting in the menu and didn't know it and thats why it is acting weird.


I have a T6 and I am fairly comfortable with it, but I have no idea what is causing your issues. As a couple of the other guys mentioned, you should be calling Canon about this. Your camera is still under warranty. But regardless, do yourself a favor and download the full user manual. And make use of it. 

 

www.canon.com/icpd

New Contributor
Posts: 4
Registered: ‎04-19-2017

Re: T6- PLEASE HELP! brand new camera, and certain functions are acting up!

Yes I am putting in a service request to get it looked at! Thanks!!

Frequent Contributor
Posts: 102
Registered: ‎06-10-2015

Re: T6- PLEASE HELP! brand new camera, and certain functions are acting up!

Put you dial in manual with the camera on.  Press the menu button and on the LCD display scroll over to the 4th wrench icon.  Select "Clear Settings".  That will put all settings back to factory.  It's something to try before sending it in for repair. 

Also since you can take a picture with live view enabled (which swings the mirror out of the way  like it does when you take a picture using the viewfinder) it may be your mirror is moving slowly causing half exposure.   That will have to be fixed by Canon.

Respected Contributor
Posts: 1,909
Registered: ‎02-17-2016

Re: T6- PLEASE HELP! brand new camera, and certain functions are acting up!

This advice is kinda hard to follow without a touchscreen or set button...

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement