Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎11-13-2017

Flash not Firing

My rebel will take a picture no problem but when I go to use the flash sometimes it won't fire and I can't figure out how to get it to fire

 

Reputable Contributor
Posts: 859
Registered: ‎02-06-2013

Re: Flash not Firing

You will only get the built-in flash to fire reliably in P, Tv, Av and M modes when you pop it up.  In the automatic modes, the flash will be used when the camera thinks you need it.

================================================
Diverhank's photos on Flickr
Occasional Contributor
Posts: 5
Registered: ‎11-13-2017

Re: Flash not Firing

I am in Manual Mode all the time but it won't fire even in AV TV P I have it popped up as it won't just pop up on its own I have to manually do that 

Respected Contributor
Posts: 1,975
Registered: ‎02-17-2016

Re: Flash not Firing

It only pops up automatically when not in P, Av, Tv or M modes. You have to manually pop it up for those. One of the reasons I use the P mode.

Occasional Contributor
Posts: 5
Registered: ‎11-13-2017

Re: Flash not Firing

I want to use m mode I know it doesn't automatically pop up I have it popped up it still don't fire and the settings are right I have had the camera for over 6 years now the problem is not know my camera or settings or what mode I am in the problem I have it popped up manually by pushing the button and I am indoors in low light which needs flash other wise the picture doesn't look right and you need that extra boost from the flash for light 

Respected Contributor
Posts: 1,975
Registered: ‎02-17-2016

Re: Flash not Firing

Which rebel?

 

Do you have it manually set for a low flash power?

Occasional Contributor
Posts: 5
Registered: ‎11-13-2017

Re: Flash not Firing

I have the T3I  

 

No I don't think so but it usually fires when ever I pop it up with no problems and now it just won't flash and I know it was something I pushed but when I did that over again it didn't fix it 

 

Reputable Contributor
Posts: 859
Registered: ‎02-06-2013

Re: Flash not Firing


ange6465 wrote:

I have the T3I  

 

No I don't think so but it usually fires when ever I pop it up with no problems and now it just won't flash and I know it was something I pushed but when I did that over again it didn't fix it 

 


Either the built-in flash bulb has burnt out or you might have had the flash turned off inadvertently...

 

Capture.JPG

================================================
Diverhank's photos on Flickr
Occasional Contributor
Posts: 5
Registered: ‎11-13-2017

Re: Flash not Firing

I am having a hard time getting in the Flash firing menu when I press set butten it takes me in Flash Comp.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement