Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 8
Registered: ‎07-18-2013

Built in flash on my Rebel T5i is not working properly.

I have had my Rebel T5i since about 2013.  A few weeks ago, I was taking some pictures inside a room with low lighting.  The camera was set on fully automatic mode, AF.  The pictures looked like they were taken with no flash.  Since then, I have practiced at home.  Even when I am as close as 3 feet to my subject, indoor pictures are dark, like the flash is not working.  I NEVER HAD THIS PROBLEM BEFORE!  Now, this week, the local police department where I work, is having Safety Town.  I always take the pictures for this event.  The first couple of pictures, taken indoors (again on automatic) were on the darker side.  Thankfully, since I learned of the issues with the built in flash prior to this event, I was somewhat prepared and brought my external flash with me.  If not for that external flash, the indoor shots would have been too dark.  Needless to say, this is upsetting.  I should not be getting dark pictures, in automatic mode, AF, 3-4 feet away from the subject!  I would like to hear from someone at Canon, who can, literally, shed some light on what could be wrong?  And having to carry an external flash with me, all the time, is not a satisfactory solution!

Honored Contributor
Posts: 6,371
Registered: ‎08-13-2015

Re: Built in flash on my Rebel T5i is not working properly.

What lens are you using?  Can you post a sample of a “bad photo” with the EXIF data intact?

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Respected Contributor
Posts: 1,929
Registered: ‎02-26-2015

Re: Built in flash on my Rebel T5i is not working properly.


@Tuffcookie wrote:

I have had my Rebel T5i since about 2013.  A few weeks ago, I was taking some pictures inside a room with low lighting.  The camera was set on fully automatic mode, AF.  The pictures looked like they were taken with no flash.  Since then, I have practiced at home.  Even when I am as close as 3 feet to my subject, indoor pictures are dark, like the flash is not working.  I NEVER HAD THIS PROBLEM BEFORE!  Now, this week, the local police department where I work, is having Safety Town.  I always take the pictures for this event.  The first couple of pictures, taken indoors (again on automatic) were on the darker side.  Thankfully, since I learned of the issues with the built in flash prior to this event, I was somewhat prepared and brought my external flash with me.  If not for that external flash, the indoor shots would have been too dark.  Needless to say, this is upsetting.  I should not be getting dark pictures, in automatic mode, AF, 3-4 feet away from the subject!  I would like to hear from someone at Canon, who can, literally, shed some light on what could be wrong?  And having to carry an external flash with me, all the time, is not a satisfactory solution!


Your camera is 5 years old.

 

Flashes do burn out. 

 

If your flash pops up, but doesn't fire it may be burned out.

 

 

Super Contributor
Posts: 245
Registered: ‎02-13-2016

Re: Built in flash on my Rebel T5i is not working properly.

Are you seeing no flash at all when you trip the shutter? Do you have anything mounted in the hot shoe that would fool the camera into thinking there's an external flash attached? Is the little switch in the one side of the hot shoe sticking in the down position?

 

Screenshot(18).png

Occasional Contributor
Posts: 8
Registered: ‎07-18-2013

Re: Built in flash on my Rebel T5i is not working properly.

I'm home from work and tried taking a 10 sec timer photo on automatic setting.  The flash did not go off!  Where do I go from here?

Esteemed Contributor
Posts: 2,385
Registered: ‎02-17-2016

Re: Built in flash on my Rebel T5i is not working properly.

Call Canon. They can walk you through it.

Highlighted
Occasional Contributor
Posts: 8
Registered: ‎07-18-2013

Re: Built in flash on my Rebel T5i is not working properly.

I contacted Canon and got instructions on mailing it into their repair center.  I have had various Canon cameras for 20 years but this is the 1st DSLR camera I have purchased.  Never have I had a built in flash unit burn out.  I certainly think it should last more than 5 years!  I will send my camera in next week and hope it is not too expensive to fix.

VIP
Posts: 9,158
Registered: ‎12-07-2012

Re: Built in flash on my Rebel T5i is not working properly.

" I was somewhat prepared and brought my external flash with me."

 

Why mess with the inferior built-in if you have a much better option?

A lot less stuff for 2018 but still a lot of Canon stuff. Along with, a lot of other stuff.
Occasional Contributor
Posts: 8
Registered: ‎07-18-2013

Re: Built in flash on my Rebel T5i is not working properly.

There are alot of times when I want to lighten my load and just carry the basic camera.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement