Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎04-08-2013
Accepted Solution

Newbie Canon C100 Questions

I have a couple quick questions on the Canon C100 as I'm planning to make the switch over from the Canon 5D.

Memory
-What memory cards would you recommend?
-How much HD video can you record on a 16GB SD card? 32GB SD card?
-What is the battery life?

-Just making sure, are Zeiss ZE mount lenses compatible?

I have a corporate video project coming up.  It is a 7 hour training session that I am to record. No editing needed just pure documentation.

I already know that a 5D isn't the best option for this job. But this job isn't the only reason for the switch or even the main reason for it. I'd like to make the C100 the main camera for my video projects moving into the future.

Thanks in advance,
Keane

Moderator
Posts: 1,005
Registered: ‎10-23-2012

Re: Newbie Canon C100 Questions

[ Edited ]

Hi keanedasalla!

 

Thank you for posting.

 

We do not have any specific cards we recommend using.  What we do recommend is that you use a high speed card, a Class 10 speed rated card for example.  Higher speed cards are needed to keep up with the amount of data that needs to be written from the camera to the card.

 

There is a chart on the specifications page for the EOS C100 on our website that lists SD card capacities and estimated recording times.  Both 16GB and 32GB is listed in the chart.  Please refer to the link below:

 

http://www.usa.canon.com/cusa/professional/products/professional_cameras/cinema_eos_cameras/eos_c100...

 

There is also a chart for estimated battery life in the manual for the EOS C100.  I have imbedded the chart below.  You should find it very helpful.

 

times.png

The EOS C100 uses a Canon EF lens mount.  Only EF mount lenses will be able to mount to the EOS C100.

 

If this is a time sensitive-matter, additional support options are available at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Occasional Contributor
Posts: 5
Registered: ‎03-25-2017

Side grip Joystick stopped working??

Hello there, 

 

U am completely new to the Canon community forum so pardon me if I am posting in the wront place.

 

I just got a canon C100 MK2 from a privata who never used it so it came with 1 hour on the 2 meters. 

 

I used it now for 10 hours and the joystick on the side grip stopped working!  Any clue? Firmwar is I think the latest the 1.0.3.1.00

 

I detached twice the side grip but always made sure the jack is plugged in properly. 

 

Anyone experienceing the same issue. The other joystick on the LCD works, thanks god! But the onw on the side grip unit is super useful!

 

Any suggestion appreciated.

 

Alfredo

Product Expert
Product Expert
Posts: 542
Registered: ‎10-17-2012

Re: Side grip Joystick stopped working??

Hello balf, 

 

This would be highly unusual for you to have this issue with the joystick not working.  I noticed that your camera did not have the most up to date firmware installed on it.  I recommend you do this to rule that out as a possible cause.  

The most current version is 1.0.4.1.00.  You can download that here

(Alternately, copy and paste this link to your browser: https://www.usa.canon.com/internet/portal/us/home/support/details/cameras/cinema-eos/eos-c100-mark-i...)

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎03-25-2017

Re: Side grip Joystick stopped working??

Hi, 

 

thank you very much for taking time to get back to me. I much appreciate it!

 

And thank you also to share the latedt update link.

 

Now, after trying to take off and put the grip back on several times, I read a post online about tring to blow some air into the socket where the jack goes before inserting it, and kind of press hard the connector in place.

 

ANd it worked! I blown some air using the lens pump thing, then press as hard as I could (which I thught I did the previous times I plugged-unplagged the connector), and magic! It works again.

 

That is a relief as although the camera has 2 joystics, the one on the hand grip it's essential!!

 

So all good. I am enjoying the camera and learnig how to use the canonLog business. 

 

Again thank you very much!

 

Alfredo

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement