Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 6
Registered: ‎02-23-2017
Accepted Solution

legria hf g40 - P Mode

hi,

 

I'm using the European HF G40 Version ("Legria") - with 25/50 frames.

 

Trying to understand how exactly "P" Mode works I had a look at my clips with the "exiftool".

 

When I set my exposure and aperture manually, it works fine. I can find my settinngs with this tool:

 

Exposure Program                : Program AE
White Balance                   : Auto
Focus                           : Auto (0)
Image Stabilization             : Off
Exposure Time                   : 1/120
Make                            : Canon
Recording Mode                  : Unknown (8)
Capture Frame Rate              : 50
Video Frame Rate                : 50
Duration                        : 12.87 s
Image Size                      : 1920x1080
Megapixels                      : 2.1
Shutter Speed                   : 1/120

 

The strange thing now is that if I use "P" instead of "TV", "AV" or "M" something like this happened:

 

White Balance                   : Auto
Focus                           : Auto (0)
Image Stabilization             : Off
Exposure Time                   : 1/100
Make                            : Canon
Recording Mode                  : Unknown (8)
Capture Frame Rate              : 50
Video Frame Rate                : 50
Duration                        : 11.43 s
Image Size                      : 1920x1080
Megapixels                      : 2.1
Shutter Speed                   : 1/100

 

Note the shutter speed! As we always learnt to take twice the capture frame rate I like this, BUT: it is not possible to enter 1/100 in manual mode or anywhere else. I can set it manually to 1/50, 1/120, 1/250 - but NOT to 1/100.

 

Does this sound reasonable? Does it work this way - "P"-Mode can use internally different Shutter Speeds (and maybe other settings) than we can set manually?

 

Or is this an issue of the software I used to list the settings? I did not find anything official of Canon to do this, I'd be happy if there  is anythinng I could use instead.

 

What happened?

Thanks

hweb

 

 

Moderator
Posts: 503
Registered: ‎11-20-2012

Re: legria hf g40 - P Mode

Hi hweb!

 

Welcome to The Canon Forums, and thank you for your inquiry!

We appreciate your participation, though we need to let you know that your product seems to be a model that is not supported by our team here at Canon USA.

The Canon Forum is hosted and moderated within the United States by Canon USA. We are only able to provide support for Canon products manufactured for and used within the US market.

If you live outside the United States, please click here and select your country or region for your support needs.

Feel free to discuss Canon products sold outside of the United States, but please be aware that you will not receive support directly from Canon USA.

Thanks for choosing Canon!

Super Contributor
Posts: 286
Registered: ‎01-13-2015

Re: legria hf g40 - P Mode

[P Programmed AE]*  - The camcorder automatically adjusts the aperture and shutter speed to obtain the optimal exposure for the subject.  *Programmed Automatic Exposure

 

I don't know if that helps but it comes from page 62 of the user guide/manual.  The available shutter speeds are available on the same page. 

Occasional Contributor
Posts: 6
Registered: ‎02-23-2017

Re: legria hf g40 - P Mode

hi,

 

thanks for your hint - this is interesting: in the German Version they list exactly what I wrote - so ..., 1/50, 1/120, 1/250, ...

 

In the American Document for the "Vixia" version on the page you noted in fact 1/100 is available in addition.

 

So for me this means: the camera is able to work with a shutter speed of 1/100, Canon just doesn't offer this in Europe for manual modes - why so ever. I don't understand, because we do have 50 fps frame rate, so it would make sense and they seem to use it internally.

 

Maybe it's worth a question to the German Support ..

 

Thanks again

hweb

 

 

Super Contributor
Posts: 286
Registered: ‎01-13-2015

Re: legria hf g40 - P Mode

Will be watching to see how this turns out and what explanation is offered.

Occasional Contributor
Posts: 6
Registered: ‎02-23-2017

Re: legria hf g40 - P Mode

I just got an answer of Canon Support Europe about this.

 

  • "P" Mode in fact might use intermediate steps for aperture / shutter speed. The output of "exiftool" looks reasonable.
  • Canon does not offer a tool to collect such Metadata out of video footage like "exifttool" does.

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement