Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎06-18-2017

Vixia HF R500 won't turn on or charge

[ Edited ]

I've had my Canon Vixia HF R500 since late 2014. I have a cross country road trip coming up and wanted to use it, so when I dug it out after not having used it for almost a year, I inserted the battery, plugged it into it's charger, and the red LED came on. An hour later, when I opened the camcorder and pressed the power button, nothing happened, now the red LED won't come on either. I'm scrambling right now to get this fixed because it's really the only camera I have besides my phone, which doesn't take the best pictures honestly.

Super Contributor
Posts: 263
Registered: ‎01-13-2015

Re: Vixia HF R500 won't turn on or charge

Have you tried powering on the camcorder, with the battery removed, using just the power adapter?  Do you have another battery you can try to determine whether or not the battery is the issue?  

Highlighted
Product Expert
Posts: 789
Registered: ‎10-16-2012

Re: Vixia HF R500 won't turn on or charge

Hi RingoMcWingo,

 

If you're still encountering this issue, please contact our technical support team. For contact options, please click here.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement