Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎12-08-2014

Re: Vixia HF 200 won't charge battery

Lawsuit? No. Don't be silly. There is no safety issue.

My camcorder is working fine now (at least the short tests I have done). No issues on battery life yet when using external charger.

It issue is a simple short circuit or solder separation. I will point out, I never removed my battery since new. The issue started on a summer trip when I (for some unexplained reason, took the battery out. I never do that). Had I left it in, it probably would still charge... but now I have two batteries and external charger that seems to do the trick.

When the unit dies for good. I will buy a Sony or Panasonic. That is the best reaction.
New Contributor
Posts: 1
Registered: ‎06-06-2015

Re: Vixia HF 200 won't charge battery (READ THIS FOR SOLUTION THAT I FOUND)

[ Edited ]

Hello,

 

I had the same problem after the camcorder sat in the back of my truck next to the ocean. I bought a new battery and it did the same exact thing. It would not charge at all through the camcorder. It also would not turn on unless I had the camcorder plugged in. I fixed the problem by putting in and taking out the battery about 10 times. It must have worked loose some of the corosion on the pins when it was sitting next to the sea all winter. It works perfect now. I am so happy.

 

6-8-2015 Update: I found that plugging the battery in and out many times did get the power to the camera, but I later found that it still would not charge properly. The one battery I bought on ebay was a clone and it appears that there is a chip inside that prevents the clones from working. The orginal battery would not take a charge I think it was shorted out by a frayed wires in the charger. The freyed wires caused the current to flow backwards out of the battery when it was not plugged in causing a dead short that killed the battery because it sat like that for many months. It appears that if the battery is a clone it must be charged on an external charger. Some clones say they have the right chip inside. If it says it is encoded, that does not mean it will charge, I think that just means it can read the level of charge left in the battery. Look the the cannon intellegent sign on the battery. But don't expect it to be cheap, I am seeing prices of 70 to 80 dollars per battery!

New Contributor
Posts: 2
Registered: ‎06-07-2015

Re: Vixia HF 200 won't charge battery

I'm glad (but not really) I'm not the only one with this problem.  Have had an FS30, with 2 batteries (the second one cost an extra $80), for 2 years and now all of a sudden it won't charge either battery.  The red light flashes 7 times, then pauses, then repeats.  The camera does work plugged directly into the wall, so it must have something to do with the internal charging system.  I guess I'll try a wall charger (if I can find one) or a new camera.  Don't think I'll be buying another Canon.

New Contributor
Posts: 3
Registered: ‎12-22-2014

Re: Vixia HF 200 won't charge battery

I opted to go with the battery on an external charger and that seems to be working just fine.  When you think about it, it's actaully easier than having the cord and everything hanging all over and it's just like a digital camera...so...whatever, it's working.

New Contributor
Posts: 2
Registered: ‎06-07-2015

Re: Vixia HF 200 won't charge battery

Yep, that's what I just did.  Found a charger for $17 that's seems to work just fine.

New Contributor
Posts: 1
Registered: ‎10-04-2015

Re: Vixia HF 200 won't charge battery

Was having the same problem with my Canon Vixia. Here's what I did:

1) Removed battery from camera

2) Wet a q-tip with WD-40

3) Using the q-tip, I wiped the contacts on the battery and in the battery receptacle

 

It works now, i.e., it charges like it's supposed to!

 

Hope this helps!

New Contributor
Posts: 1
Registered: ‎11-06-2015

Re: Vixia HF 200 won't charge battery + Canon LEGRIA HF S21

The same happen with my Canon LEGRIA HF S21 !

The camera flashes 7 times, then aborting charging.

I've used a fully charged battery... once empty the

camera will not charge it again !

- Used another power-supply, .... no change, no charging...

- Re-charging the same battery on another camera - worked !

- Connectors clean on battery and inside the camera.

Must be the electronics circuit in the camera.

Strange, because the camera can monitor the status of the

original battery and switch between the ext. battery and the

external power-supply. So all the 4 connectors (+,D,T,-)

must be functional. I've checked them visually... gold plated,
no oxidation... should be OK. Compared to a another camera,

the same "picture".

OPTION 1 - CAMERA-Repair...

OPTION 2 - a separate battery charger.

If someboby could send me a service-manual, then I could

try to follow the signals from cameras battery-connector to

the charging-IC and analyzing the circuit around it.

 

New Contributor
Posts: 2
Registered: ‎04-01-2016

Re: Vixia HF 200 won't charge battery

Same problem here.  Bought an external charger that solved the problem.  Found the charger on Amazon for $15, manufactutred by STK for the specific battery in the HF 200.  Good solution, really.  The external charger is a better system than the original adapter cable. 

Occasional Contributor
Posts: 11
Registered: ‎10-19-2016

Re: Vixia HF 200 won't charge battery

VIXIA HS20 won't charge battery and won't hold a charge.


I purchased the camera in 2011.

I have two dead Canon branded batteries.
I have tried three off-brands so far.

Blinks seven times slow, 1-2 second break, blinks seven.

Have tried to charge for 18 hours, 12 hrs. and 2 days.


The best charge I can get is 78 minutes. If I check and just leave, the battery drains to 48 minutes in less than 20

So, the answers to what to do when the battery won't charge doesn't answer:

If your camcorder works fine with power, and your batteries won't charge.

Now what?

 

Occasional Contributor
Posts: 11
Registered: ‎10-19-2016

Re: Vixia HF 200 won't charge battery

Did the external battery charger help? This is exactly what is happening to me now with my five year old HFS20 Vixia. Camera works fine on power. No battery charge and if I attempt to use the battery and try again, the depletion is about 30%.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement