Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 5
Registered: ‎01-27-2013

Vixia HF 200 won't charge battery

Hi,

 

I have a HF 200 which has served me well over the years.  Now when I plugged in the original Canon power adapter, the red LED will flash 7 times in about 7 seconds, and then rest for about 5 seconds.  The battery does not charge and it's the original Canon battery.  I can use a compatible battery charger and the battery will charge.  However, it won't display the remaining time properly and it will alert me to change battery all the time.  I bought a new battery which initially  worked fine, displaying the remaining time properly.  But the camcoder won't charge it.

 

Is the problem with the power adapter?  Is there a replacement?

 

Or is the problem with the camcorder?  Given its age, I probably don't want to fix it.  if so, is there a compatible charger that I can buy?

 

Thanks

 

 

Product Expert
Posts: 768
Registered: ‎10-16-2012

Re: Vixia HF 200 won't charge battery

Hi Cheerful,

 

For information regarding a replacement  for your CA-570 Compact Power Adapter, I recommend checking with our Sales and Accessories Department.  You may reach them by calling (800) 652-2666 between 8:00 AM and midnight ET, seven days a week.  They'll assist you with product information and dealer locations.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Occasional Contributor
Posts: 5
Registered: ‎01-27-2013

Re: Vixia HF 200 won't charge battery

Is the problem fixable by a new adapter?  Or it's really inside the camcorder?

 

Thanks

Moderator
Posts: 1,005
Registered: ‎10-23-2012

Re: Vixia HF 200 won't charge battery

Cheerful,

 

Based on everything you described, the replacement adapter is the best way to go.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 2
Registered: ‎12-06-2013

Re: Vixia HF 200 won't charge battery

Hi Cheerful,

 

  I'm seeing the same issue.  Was your problem fixed by getting a new adapter?

 

Thank you,

toru

New Contributor
Posts: 4
Registered: ‎02-15-2014

Re: Vixia HF 200 won't charge battery

I have two batteries and neither will charge, I used a charger from my other Canoncam corder and still will not charge. The charging light seem to be flashing a lot faster also.

Occasional Contributor
Posts: 6
Registered: ‎11-28-2012

Re: Vixia HF 200 won't charge battery

cheerful,

          So this makes like 3 or 4 of us having the exact same issue?  I too just reported a similar problem with my Canon HF21 HD camcorder to tech support a few hours ago.  Saaaame thing 7 flashes 3 second pause and then repeats.  My red screen shows up on startup " ! Charge the camcorder battery"(or something like that) shows up and the red battery up in the upper right shows up and won't go away.  I bought a charger (thinking mine is bad) from an electronics store specifically for the Canon batteries and charged them fully proving it wasn't the batteries, put them back on my unit and immediately got the same error witht the red battery in the upper right corner of the screen and another error message saying " ! Charge the camcorder battery".  I mean...I've been using these batteries flawlessly for years and the likelyhood of both failing on the same day was slim to none...so I really knew it wasn't the batteries.  I can't believe the Canon personell haven't addressed this issue of that red battery indicator not going away with a perfectly fine battery??.  It doesn't sound like a fix by purchasing a new CA-570??  What ultimately will fix this tech support?  Anyone?

Moderator
Posts: 1,005
Registered: ‎10-23-2012

Re: Vixia HF 200 won't charge battery

Hi WHITETAIL!

 

Thanks for posting.

 

If charging the battery with another charger works, yet you still see the same screen and message on the camcorder, something is wrong with the camcorder itself and will need to be repaired.  To start the repair process, you'll need to complete a Repair Request on our website.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 3
Registered: ‎10-20-2014

Similar problem using VIXIA HF M301

Hi, WHITETAIL!

 

I just posted a similar issue for the VIXIA HF M301.  I wonder if it is a failure where the AC adapter plugs into the camcorder which could explain the issue on different models.  If Canon has not addressed this problem, I question paying for an authorized repair when it would just happen again.

Occasional Contributor
Posts: 6
Registered: ‎11-28-2012

Re: Similar problem using VIXIA HF M301

Lisa, I was just dealing with the battery problem on my camcorder by keeping two batteries with me at all times. Then one day the battery indicator just reappeared don't know how don't know why it just reappeared everything's been working fine since then. And when I say it fixed itself I probably only went two weeks if that with it being broken? I'm guessing it was some kind of glitch? I don't know I'm not that tech savvy but I'm just glad it's fixed.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement